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Overview:

SquareDesk is the latest Beta test version of SquareDesk, a fully-featured music player, lyrics 
editor, and sequence designer designed for square dance callers.  SquareDesk contains a powerful 
MP3 player with independent pitch and speed controls, a quick-search facility, a 3-band equalizer, 
and a powerful automatic timer capability.  It provides a built-in copy of “sd”, one of the best square 
dance sequence designers available, adding a graphical view of the square.  The Reference tab 
provides access to TXT, PDF, and HTML files, and you can even run a copy of Taminations here, if 
you want to.  SquareDesk is native on Mac OS X, Windows, and Linux, so it's fast and responsive.  
SquareDesk is also free (as in beer).

The source code is available at GitHub as Open Source under GPL2/GPL3 licenses, so that 
others can develop new features as well.  

I'm looking for general comments, specific comments, suggestions, and especially bug reports.
Any feedback you can provide would be helpful!



Prerequisites:

Mac OS X 10.7 (untested) Lion (initial release: July 2011)
Mac OS X 10.8 (untested) Mountain Lion (initial release: July 2012)
Mac OS X 10.9 (untested) Mavericks (initial release: October 2013)
Mac OS X 10.10 (untested) Yosemite (initial release: October 2014)
Mac OS X 10.11 (untested)  El Capitan (initial release: September 2015)
Mac OS X 10.12.3 (tested)  Sierra (initial release: October 2016)
Mac OS X 10.13.2 (tested) High Sierra (initial release: June 2017)

Windows 7 (untested) (initial release: October 2009)
Windows 8 (untested) (initial release: October 2012)
Windows 10 (tested) (initial release: July 2015)

Linux (untested) (coming soon)

Getting started (Mac OS X):

 1. Make sure you are running Mac OS X 10.13 (High Sierra) .  Earlier versions of Mac OS may 
work, but they have not been tested.  Let me know what you find!

 2. Install SquareDesk by double-clicking on the DMG file, and dragging the SquareDesk icon to 
the Applications icon.

 3. If you ever need to uninstall, just drag SquareDesk from your Applications folder to the Trash. 

Getting started (Windows):

1) Make sure you are running Windows 10 (with the latest updates).  I have not tested Windows 7
or 8, but they might work. Sorry, but Windows XP is known NOT to work (and it's no longer 
supported by Microsoft either, since it's now 15 years old).

2) Install SquareDesk by double-clicking on the SquareDesk_0.8.3_setup.exe file, and 
following the instructions.

3) If you ever need to uninstall, navigate to the installed SquareDeskPlayer directory (e.g. in 
“C:\Program Files\SquareDesk”), and double click on the uninstaller uninst.exe .

4) On older versions of Windows, you may get a “missing api-ms-win-crt-runtime-l1-1-0.dll” 
error when you try to run SquareDesk. This did not happen for me on Windows 10, but it has 
happened to me before on Windows 7.  I have not tested Windows 8.

To install these required DLL components on older systems, you can download and run 
vc_redist.x86.exe from Microsoft, from this location:

 https://www.microsoft.com/en-us/download/details.aspx?id=52685



Start using SquareDesk (MacOS/Windows):

 1. There is an optional “Startup Wizard” to help you create the main Music Directory and 
subdirectories, and to copy some initial MP3 files into it.  Select File > Startup Wizard... to get 
step-by-step help with the initial setup.  You generally won't need to do this more than once.

Note that the Startup Wizard won't actually do anything until you click on “Done” on the last 
page of the wizard.

 2. If you want to skip the Startup Wizard, and you prefer to setup the directories by hand:

(a) first create a directory to hold your music files (e.g. C:\squaredancemusic on Windows, 
or /Users/<your name>/squaredancemusic on Mac OS X).

(b) Within that Music Directory, create the following subdirectories/folders:  patter, singing, 
vocals, xtras. You can actually use any names you like, but the names “patter”, “singing”, 
“vocals”, and “xtras” are special, and will be specially colored in the music selection pane. 
These names and colors can be customized in the Preference dialog.

Automatic Beat Per Minute (BPM) detection is turned off for songs in the “xtras” folder, and 
Loop defaults to ON for songs in the “patter” folder.  It would also be a good idea to create 
a subdirectory called “playlists”, to hold the CSV/M3U playlist files.

(c) Although you can still open individual MP3 files using SquareDesk, it's a lot easier to 
choose music from the list in the bottom pane.  Go into Preferences and set a Music 
Directory path for your music (SquareDesk will remember your choice here).  Set that 
Music Directory to the directory you created in Step 1 above.

(d) Put some music files into the subdirectories by copying them there.  

NOTE: You can use Aliases, if you want, to save disk space, but be sure that the alias 
names end in “.mp3” and not “alias”.

 4. Music filenames should look like this:  

RR 123 – Lovin' You.mp3

where RR123 is the label and record number, and “Lovin' You” is the name of the song.  If you 
follow this naming convention (and most of the record labels are now using this convention, or 
something close to it), the music selection pane will let you sort by individual fields, including 
label, label number, type, and title.  

If your files are the other way around, e.g. Lovin' You - RR 123.mp3, you can now change the 
filename style in the Preferences dialog.  If you use a mix of styles, there's also a “take your 
best guess” option that can work for most filenames.

 5. Searching:  Type something into the Label, Type, or Title fields to search your music titles for 
matches. Anything containing the string you type will remain in the music selection pane.  Note
that the search fields work together – you'll only see songs where there is a match for all of the
fields that are not blank.  Click Clear Search to go back to showing all your music.  



 6. Sorting: Clicking on “Type”, “Label”, or “Title” in the header row in the song table will sort by 
that column.

 7. Loading music for playback: Double-click on a music file to load it.  When loaded, the title of 
the song (without the Label part) will appear above the time bar.  Note that double-clicking will 
not start playback immediately (unless you want it to, see the Autostart Playback feature 
below).

 8. You can then play/pause the music, and change tempo and pitch and volume independently. 
There's also a 3-band Equalizer (EQ) to balance the bass, midrange, and treble of your music. 
The Mix slider (aka “Balance”) is designed for balancing music/background vocals, where 
music is on the L channel, and BGV's are on the R channel (Riverboat has a number of 
releases that have this feature).

 9. Hold down the Control key and click on a song (or Right click on a song), then select “Reveal 
in Finder” (Mac OS X) to open the folder containing that song.

 10.Most functions are also found in the pull-down menus at the top.  In addition, there are 
keyboard shortcuts for most common operations (see the Keyboard Shortcuts section below).

Preferences:

 1.  There are several Music preferences settable on the Music tab of the Preferences Dialog.

(a) Music Directory: Click on “Choose...” to pick a new directory where you have music.

(b) Music Names: Choose the naming style that you prefer, either “Label – Title” or “Title – 
Label” or “Best guess (or a mixture of both formats”.  Guesses won't always be correct, but 
they're right about 99% of the time.

(c) Music Types:  You can choose your own names for the subdirectories of the Music 
Directory that hold your patter, singing calls, etc. If you use more than one name for a 
particular type, separate the names by semicolons. Each type also has a color, that is used
in the searchable song table, and in the Clock Coloring option (see below).  Set the color to
#FFFFFF to reset it to the default color.

For example, you might want to put Christmas patter records into <Music 
Directory>/Patter/Christmas.  In this case, their Type will be “Christmas”, but they will also 
be treated as Patter.

(d) Behavior:  When you start playing a singing call, checking this box will tell SquareDesk to 
automatically take you to the Lyrics tab (if lyrics are available).

(e) Sessions:  SquareDesk keeps track of how long ago you played each song in the new 
“Age” column.  It keeps track of each day-of-the-week separately (if you choose “Default to 
current day of the week”) or it just keeps track of all songs in the same bucket (if you 
choose “Default to 'Practice' session). 



 2. On the Hotkeys tab of the Preferences Dialog, you can change what keys are used to access 
each SquareDesk function.  To assign a new hotkey, click on an existing entry in the Hotkey 
column, and then press the new hotkey on your keyboard.

 3. There are several Experimental features available in the Experimental tab:

(a) Timers tab: provides very simple count-up and count-down timers.

(b) Enable Clock Coloring by Song Type: If enabled, playback will create parts of a color-
coded ring around the outside of the clock.  Each minute within the hour is color-coded by 
the song type that was played last in that minute.  This allows you to see how long your 
patter and singing calls ran during the last hour.  The colors are the same as chosen in the 
Music tab of the Preferences dialog.

(c) Break timer:  SquareDesk keeps track of how long you haven't been playing music.  When
you are in break, a break timer will appear above the analog clock (e.g. “BK=6:30”).  If you 
haven't been playing anything for more than N minutes (you choose N), a red message will 
appear “BREAK OVER”.

SquareDesk now uses a “zero touch” method for determining when the break starts and 
ends.  This method doesn't require remembering to click a button to start the break.  
Whenever your singing call ends (or any other non-patter song ends), the break will 
automatically start.  If you pause your patter for more than 30 seconds, the break will also 
automatically start (minus the 30 seconds that have already elapsed). You can restart the 
break timer by clicking once on the “BK=mm:ss” text.

(d) Long tip warning:  SquareDesk keeps track of how long you have been playing Patter.  If 
your patter has gone on for more than M minutes (you choose M), a red message will 
appear “LONG TIP”, to remind you to move on to the singing call, or give the dancers a 
break.

SquareDesk now uses a “zero touch” method for determining when the patter section of the
tip starts and ends.  This method doesn't require remembering to click a button to start the 
patter timer.  Whenever you play patter, the patter timer will start.  If you pause your patter 
for less than 30 seconds, you'll stay in Patter mode.  You can restart the patter timer by 
clicking once on the “PT=mm:ss” text.

(e) 30 second warning:  When checked, will play the 
<MusicDirectory>/soundfx/thirty_second_warning.mp3” file (without stopping the music).  
The default sound is a verbal warning, but you can overwrite this file with any sound you 
prefer.

(f) Set song's initial BPM:  When checked, SquareDesk will always try to set the tempo 
(beats per minute) to your selected value, when a song is loaded.  If it can't do so, it will set 
the tempo to 100%, and you can adjust it manually from there.  This only works once for 
new songs – after that, SquareDesk will remember the new tempo as your preference for 
this song.

(g) Show time remaining: Select this option, if you prefer to see Time Remaining in the song, 
rather than the current time within the song. 



Music tab:

 1. Many of the music transport controls may be already familiar to you.  All of these functions are 
available via the Music menu, or by clicking on an item in the Music tab.  In most cases, you 
can use either the hotkey (e.g. ⌘M), or the key alone, without the Command key (e.g. just M).

(a) STOP button: stops playback, and rewinds the play position to the beginning.  Pressing 
the ESC key twice will first clear the search fields, and then will stop playback.

(b) PLAY/PAUSE button: if the player is currently NOT playing, pressing this button will begin 
playback.  If the player is already playing, pressing this button will pause playback at the 
current position.

(c) PREVIOUS/NEXT SONG buttons: stops playback, and loads the previous/next song 
visible in the song list.

(d) Music slider: you can click and drag the music slider button at any time to move the play 
position to a new spot.  Clicking on the music slider to the right or left of the current play 
position will move the play position to that spot.

(e) Tempo slider: changes the tempo, without changing the pitch.  This setting is remembered
on a per-song basis.

(f) Pitch slider: changes the pitch, without changing the tempo. This setting is remembered 
on a per-song basis.

(g) Volume slider: changes the volume of the song.  Note that the main system volume 
control will affect the volume of all songs. This setting is remembered on a per-song basis.

(h) Mix slider: changes the balance between the L and R channels.
(i) Type, Label, Title fields: typing anything in these fields will narrow the search.  Press ESC

once or press the Clear Search button to clear this field.
(j) Three-band EQ sliders (B/M/T): changes the Bass, Midrange, and Treble.  These settings

are remembered on a per-song basis.
(k) VU meter: shows the instantaneous audio output level (Green = OK, Red = High)
(l) Patter Timer (PT):  shows how much time you've been playing patter.  Click once on the 

“PT=MM:SS” (when visible) to reset the Patter Timer to zero.
(m) Music list: shows all of the music in your Music Directory.  Click on a column heading to 

sort that column.  Right click (or Control-click) on a song to get a song-specific context 
menu (e.g. add to playlist, or reveal in Finder).

 
 2. Playlists (the “#” column in the song list) are supported:

 
(a) A Playlist is an ordered list of songs, saved in a Playlist File (either a .csv or .m3u file). 

(b) You can put Playlists anywhere you like on your hard drive, but remember that they contain
the full pathname to your songs.  If you move the songs themselves, your current playlists 
will not find them.

(c) To add an item to a Playlist, or to move an existing song to the top/bottom of a Playlist, you 
can either:
 i. Select Playlist > Add to Playlist > at TOP (Mac OS shortcut: ⇧⌘←)
 ii. Select Playlist > Add to Playlist > at BOTTOM (Mac OS shortcut: ⇧⌘→)
 iii. Right Click (or Control-click) on a song: Add to TOP of Playlist
 iv. Right Click (or Control-click) on a song: Add to BOTTOM of Playlist
 v. Manually add a number to a song in the “#” column. 



 NOTE: You'll need to click on the blank area in a cell, and then click again a few 
 seconds later (it works just like you change a filename in the Finder/Explorer).

After setting some numbers, you probably want to click on the # column header to sort 
by number. Songs will be written to the Playlist in “#” order.

(d) Once an item on the Playlist is selected, you can easily move it up/down in the playlist 
order:
 i. Select Playlist > Move song > UP in Playlist (Mac OS shortcut: ⇧⌘↑)
 ii. Select Playlist > Move song > DOWN in Playlist (Mac OS shortcut: ⇧⌘↓)
 iii. Right Click (or Control-click) on a song: Move to TOP of Playlist
 iv. Right Click (or Control-click) on a song: Move UP in Playlist
 v. Right Click (or Control-click) on a song: Move DOWN in Playlist
 vi. Right Click (or Control-click) on a song: Move to BOTTOM of Playlist

(e) To remove an item from the Playlist:
 i. Select Playlist > Remove from Playlist (Mac OS shortcut: ⇧⌘⌫)
 ii. Right Click on a song: Remove from Playlist

(f) HINT: You could put the same number on more than one song, but when that Playlist loads
again, the order might not be the same.  It's a lot more predictable to give each song in the 
Playlist a unique number.

(g) Click on the >>| button to go to the next song in the song list.  Click on the |<<  button to go 
to the previous song in the song list.  

NOTE: These buttons do not go to the next numbered song, they go to the next 
song in the currently visible sort order.  If you want to go to the next song in 
playlist, make sure that the songs are sort by the “#” column.

(h) Select Playlists > Clear Playlist to clear all the Playlist numbers.  The Tempo and Pitch 
you've selected in the current session are not affected.

(i) Hint:  You could setup a playlist for each Club you call for, or try the Sessions feature.

 3. SquareDeskPlayer supports an experimental “Guest Mode”.

If a guest caller plugs in a Flash drive containing a top level folder called “squaredancemusic”, 
and there are subfolders containing MP3 files, the filenames will be loaded and merged with the 
songs from your drive into a single unified list. 

When Guest Mode is active, type fields (based on subdirectory names, just like the normal 
SquareDesk Music Directory in Preferences) will show a “*” to indicate that the song is available 
only on the external flash drive. 

You can then search for and play songs from the external flash drive just like any other song. 
Remove the flash drive, and the songs will disappear from the song table.

This feature allows callers to bring their music on a flash drive, rather than bringing an entire 



laptop that needs to be connected to the host's sound system. 

Currently, saved Tempo/Pitch/etc from the Guest Mode flash drive are not used.  In the future, 
this feature will likely be able to take advantage of guest pitch/tempo settings, etc. as well.

 4. The Session menu provides a way to choose how to track Age, Pitch, and Tempo on a per-
song basis.  Each session represents a different set (or “bucket”) of settings.  Consider using a 
session for each of your clubs.  If you call for different clubs on different days of the week, there's 
a Preference to automatically switch to that club's Session, when SquareDesk starts.

 5. The View menu provides two options:

(a) Compact mode: removes some of the user controls to show a simpler interface.
(b) Enter Full Screen: makes the SquareDesk window as big as it can be (often used on laptop

computers)

Lyrics/Patter tab:

 6. The Lyrics tab: provides a separate tab for Lyrics (or Patter) text associated with a song.  
Currently, the lyrics must either be:

a) a .txt, .htm, or .html file located in the same directory as the singing call, with the 
same base filename (e.g. “Rocky Top.htm” or “Rocky Top.txt” would be the lyrics that go
with “Rocky Top.mp3”), or

b) [MAC ONLY] embedded in the MP3 file itself (NOTE: iTunes/Mac can add lyrics to an
MP3 file: select the file, right click and choose Get Info, and click on the Lyrics tab).

In either case, if lyrics are available, the “Lyrics” tab will change to “*Lyrics” (with a star) 
to indicate that lyrics have been loaded.  Click on the Lyrics tab to view the lyrics.  While
in the Lyrics tab, you can scroll up and down with the mouse wheel, or using Page 
Up/Down keys.

 7. To download lyrics that might match your singing calls, you don't have to download all the 
lyrics for all singing calls.  Choose File > Download Matching Cuesheets..., and we'll check to 
see which cuesheet/lyrics files might match, and we'll download them for you, to the 
<MusicDirectory>/lyrics/downloaded folder.

 8. If more than one cuesheet/lyrics file name matches the currently loaded song, all of the 
matches are available in a dropdown menu on the Lyrics/Patter tab.  Choose the one you 
want, and SquareDesk will remember your choice the next time that song is loaded.

 9. On the Lyrics tab, you can also set end-of-Introduction (“Intro”)  and start-of-last-section 
(“Outro” = opposite of “Intro”) points for singing calls. By doing so, the colors that indicate 
which verse you're in will show the correct times.  These settings will be remembered on a per-
song basis.

 10. When a Patter song is loaded, this tab becomes the “Patter” tab.  You can have text 
associated with Patter songs, using the same file naming scheme as for Lyrics.  If Patter is 
loaded, the Intro/Outro buttons become Start and End Loop buttons.  Use Music > Test Loop...



to fine-tune your loop endpoints (to the millisecond).

 11. When Lyrics/Patter text is loaded, you edit that text, by clicking on the LOCK button to unlock 
for editing.  When done, click Save As... to save your changes under a new name.  Or, check 
Auto-Save, and your changes will be saved automatically.

(a) When editing text, select the text, then click a button to change the formatting.
(b) To clear all formatting, select the text, then click Clear Formatting.
(c) Text can have only one of the following formats:  Title, Label, Artist, Header, Lyrics.
(d) Any text can also be made bold or italic.

Start using the built-in version of SD (MacOS/Windows):

 1. The manual for using SD is quite detailed, so this section is just a summary of how to get 
started.  Please refer to the sd manual for the details of how to use sd.

 2. If you don't already have an 'sd' directory in your Music Directory, SquareDesk will ask to 
create one. This is where sd will put saved sequence files.

 3. On the sd tab, you'll find several panes:
(a) the lower left pane allows you to type in sd commands and square dance calls
(b) the upper left pane shows either the current sequence, or all output from sd
(c) the upper right pane shows a graphical representation of the square
(d) the lower right pane show some of the calls you can double-click

 4. To start, try typing in “heads start”.  (Other choices might be “sides start” or “heads 1p2p”.



 5. Continue with some calls:  “square thru 4”, “swing thru”, “boys run”.
 6. You can change the appearance of the checkers via the SD menu:

(a) Normal: checkers have numbers and colors
(b) Color only: checkers have colors, but not numbers
(c) Mental Image: only the #1 Man has color, nobody has numbers (useful for practicing Don 

Beck's Out of Sight method)
(d) Sight: The #1 and #4 couples have colors, nobody has numbers.  Useful for 2-couple Sight 

calling.
 7. Keyboard shortcuts:  TAB to auto-complete the current call
 8. [MAC OS X and Windows only]  On MacOS X and Windows, you can also use your 

microphone to verbally enter Plus-level calls.  Note that the microphones on your machine 
are probably very sensitive, and they will pick up noise that the application will try to 
convert to calls.  So, try to work in a relatively quiet environment, or use a headset, for 
better success.  Try saying:  “heads start”, “square thru four”, “swing thru”, “boys run”.

 9. Verbal shortcuts:  “square your set” is a shortcut for “abort this sequence, yes”.  “Left bracket”
and “Right bracket” can be spoken to insert '[' and ']', which is what sd uses to create correctly-
nested calls. For example, you can verbally say “Follow your neighbor and Spread”, and 
SquareDesk will convert that to what sd wants to see: “[follow your neighbor] and spread”.  
Alternately, you can make the nesting explicit by saying “left bracket follow your neighbor right 
bracket and spread”.

 10. Voice input can be toggled via the SD > Enable Voice Input menu item, or by pressing Cmd-I.
 11. Note: the automated speech recognizer only recognizes valid Plus-level calls, and it prefers 

them in the exact format that sd likes.  This will improve over time, and I'd appreciate hearing 
about any valid Plus calls that the recognizer doesn't understand.

 12. Although you can say “square your set” verbally, right now to do it from the keyboard requires 
that you type “Abort this sequence”, and then “yes”.

Dance Programs tab:

It is convenient to track what you've taught in your classes using the Dance Programs tab.  If 
you have a custom teaching order, create a file in <MusicDirectory>/Reference/XXX.YYYY.txt, 
where 0XX is a three-digit number starting with zero, and YYY is the name of the teaching 
order.

The XXX number determines the order in the Dance Program dropdown list.  The YYY is the 
name that will appear in the dropdown list.

Inside that file, each line should have a Teach order number/name, a comma, and the name of
the call.

For example, 010.Blast Class.txt might look like this:

 1, Circle Left / Circle Right
 2, Forward and Back
 3, Dosado / Dosado to a Wave



 4, Swing
…

Click on a checkbox to mark that call taught.  The date will be automatically recorded.

Click Clear Checks, to clear all of the checkmarks (e.g. if the class is starting again).

Reference tab:

A .txt, .pdf, or .htm file placed into <MusicDirectory>/reference will show up here.  Each file will 
show up as a separate tab.  If your filename starts with a three digit number starting with “1”, 
you can control the order that the documents will show up as tabs.  For example, “100.Basic 
Definitions.pdf” (a Callerlab definitions document) would show up as the first tab.

Hint:  You can download a copy of Taminations from here:

https://www.tamtwirlers.org/tamination/info/download.html

Unpack it into a Taminations folder in your <MusicDirectory>/Reference folder, and 
Taminations will be available in the Reference tab.



FAQ (Frequently Asked Questions):

Q1. What does the LOOP function do?  
A1. If LOOP is on, the playback head will automatically jump from the blue right bracket (“]”) point 
back to the blue left bracket (“[“) point.  Patter records default to LOOP ON, and SquareDesk will turn 
it OFF by default for anything else.  You can turn LOOP on/off via the Music > Loop menu item, or via
the L key.  Your choice is remembered on a per-song basis.

Q2. What does the STEREO/MONO button do?
A2. For those callers with stereo speaker setups, you'll want to stick to Stereo mode.  If you have only
one speaker, you probably want audio from both L and R channels to play on that speaker.  To do 
this, choose Force Mono mode from the menu.

If you are using a mono cable with a stereo mixer only one channel of the music is going to your 
speakers.  To fix that without having to buy an adaptor or a new cable, just turn on Force Mono mode.

Q3. What does the MIX slider do?
A3. Some square dance record producers (like Riverboat1) are putting an instrumental track on the L 
channel, and harmonies on the R channel.  Similarly, some round dance music has the instrumental 
track on the R channel, and spoken cues on the R channel.  The MIX slider lets you fine-tune the 
relative levels of instrumentals vs harmonies/cues.

Q4. What is 3-band EQ?
A4. SquareDeskPlayer provides 3 bands of equalization: B (Bass), M (Midrange), and T (Treble).  
Adjust these to taste.

Q5. What does the Autostart Playback menu item do?
A5. If you enable this feature, double clicking on a song will load it AND it will start playing 
immediately.  SquareDesk will remember your preference for this feature.

Q6. Have you tested SquareDeskPlayer on all versions of Mac OS X?
A7. No.  It seems to work fine on 10.13 (MacOS High Sierra).  Feedback on other versions would be 
appreciated!

Q8. What Playlist formats does SquareDesk use?
A8. SquareDeskPlayer supports both M3U (MP3 playlist) and CSV (Comma Separated Values) 
formats.  Only the CSV format supports saving tempo and pitch information.  Pathnames are full, 
absolute pathnames, so you can move around the playlists, but you can't move around your music.  If
you do move your music, you can use a text editor to manually edit your M3U/CSV playlists, or you 
can also use Open Office or Excel to edit your CSV playlists.

Q7. What's CSV?
A7. CSV is an industry standard format used for spreadsheets.  It consists of a header line that 
describes the column names, and one row for each record.  Currently, there are exactly three fields 
per row:

1) Absolute pathname to the music file (must be surrounded by double quotes)
2) Pitch change to apply (semitones from no change, 0 = no change; no double quotes)
3) Tempo change (0 = no change, <number> = BPM, <number>% = percentage of the 

original tempo, e.g. 105%, no double quotes)

1 Riverboat Records has several examples of this type of 2-channel music, with Instrumentals on L, Harmonies on R.



Q8. What's the Windows version look like?  Is it compatible with the Mac version?
A8. The Mac OS X and Windows versions are 100% compatible.  The Windows 10 version looks like 
this:

Q7. Can I access my music directly from both Mac OS X and Windows machines?
A7. Yes.  Here's how I do it, using Dropbox:

a) Set up Dropbox (dropbox.com) on both of your machines, and signup for the free (currently 
2GB) account.  [Note: You could also use iCloud, Box.net, Google Drive, or other
cloud storage solutions]

b) Put all of your music into a shared Dropbox folder.
c) Wait for it to be copied to the Dropbox Cloud, and then let it sync to your other device.
d) On each device, one at a time start SquareDesk and set the MusicDirectory to be your

shared music folder, then quite SquareDesk.
e) You can now use SquareDesk on one machine or the other.  Note that there's only one

database here that is copied to both machines.  If you make changes on one
machine, Dropbox will copy the database to the other machine, overwriting the
one that was there. 

f) SquareDesk will warn you if both machines try to access the database at the same time.
You should make sure that only one copy of SquareDesk accesses the 
shared MusicDirectory at a time.

g) If you buy a new song, and copy it into the Music Directory on one machine, Dropbox
will automatically copy it to the MusicDirectory on your other machines.  
SquareDesk will also automatically pick up any new files that show up in 
the Music Directory while SquareDesk is running.


